VMT(4) BSD Kernel Interfaces Manual VMT(4)
vmt -- VMware Tools driver
vmt0 at mainbus0
The vmt driver is a kernel level implementation of VMware Tools. VMware
Tools are intended to provide better support for operating systems run-
ning inside virtual machines.
vmt handles shutdown and reboot requests from the host by signalling
init(8) with SIGUSR2 and SIGINT respectively. vmt will log notifications
that the guest has been suspended or resumed by the host. It also pro-
vides access to the host machine's clock as a timedelta sensor.
vmt reports the guest's hostname and first non-loopback IP address to the
init(8), sensorsd(8), sysctl(8)
A vmwh helper program is available via packages(7).
The vmt driver first appeared in OpenBSD 4.4.
The vmt driver was written by David Gwynne <firstname.lastname@example.org>.
BSD April 27, 2017 BSD