VIRTIO(4) BSD Kernel Interfaces Manual VIRTIO(4)
virtio -- VirtIO support driver
virtio* at pci?
The virtio driver provides support service for paravirtualized devices
using the VirtIO protocol. Such devices are provided by bhyve, KVM,
QEMU, and VirtualBox.
Currently there are drivers for the following virtio devices:
vio(4) VirtIO network device
vioblk(4) VirtIO disk
viomb(4) VirtIO memory ballooning driver
viornd(4) VirtIO random number device
vioscsi(4) VirtIO SCSI adapter
The virtio driver first appeared in OpenBSD 5.3.
The virtio driver was ported to OpenBSD and improved by Stefan Fritsch
<firstname.lastname@example.org>. It is based on the NetBSD driver by Minoura Makoto.
BSD May 25, 2017 BSD