VIO(4) BSD Kernel Interfaces Manual VIO(4)
vio -- VirtIO network device
vio* at virtio? flags 0x00
The vio driver provides support for the virtio(4) network interface pro-
vided by bhyve, KVM, QEMU, and VirtualBox.
Setting the bit 0x2 in the flags disables the RingEventIndex feature.
This can be tried as a workaround for possible bugs in host implementa-
tions of vio at the cost of slightly reduced performance.
Setting the bit 0x100 in the flags forces the interface to be always in
promiscous mode. This can be used as a workaround for a bug in QEMU
before version 1.7.2 that prevents packets with a VLAN tag from being
sent to the guest.
The vio driver first appeared in OpenBSD 5.3.
The vio driver was ported to OpenBSD and improved by Stefan Fritsch
<firstname.lastname@example.org>. It is based on the NetBSD vioif driver by Minoura
BSD May 25, 2017 BSD