VIASIO(4) BSD Kernel Interfaces Manual VIASIO(4)
viasio -- VIA VT1211 LPC Super I/O
viasio* at isa? port 0x2e flags 0x0000
viasio* at isa? port 0x4e flags 0x0000
The viasio driver provides support for the VIA VT1211 LPC Super I/O IC.
The hardware monitoring and watchdog timer functions are currently sup-
The hardware monitor provides hardware monitoring capabilities to be used
with the sysctl(8) interface. The following monitoring sensors are
Sensor Units Typical use
TEMP1 uK Pentium II type thermal diode
UCH1 uK or uV DC CPU temperature
UCH2 uK or uV DC System temperature
UCH3 uK or uV DC CPU core voltage
UCH4 uK or uV DC +5V
UCH5 uK or uV DC +12V
+3.3V uV Internal +3.3V
FAN1 RPM Fan tachometer
FAN2 RPM Fan tachometer
If the hardware monitor is not enabled by firmware, the driver can try to
enable it if value 0x0001 is present in the flags. Note that enabling
the hardware monitor can lead to unexpected results.
The watchdog timer provides a standard watchdog(4) interface. If the
watchdog timer is not enabled by firmware, the driver can try to enable
it if value 0x0002 is present in the flags.
intro(4), isa(4), watchdog(4), sensorsd(8), sysctl(8)
The viasio driver first appeared in OpenBSD 3.8.
The viasio driver was written by Alexander Yurchenko
BSD April 26, 2017 BSD