VGE(4) BSD Kernel Interfaces Manual VGE(4)
vge -- VIA Velocity 10/100/Gigabit Ethernet device
vge* at pci?
ciphy* at mii?
ipgphy* at mii?
The vge driver provides support for various NICs and embedded Ethernet
interfaces based on the VIA Networking Technologies VT6120, VT6122,
VT6130 and VT6132 Gigabit Ethernet controller chips, including the fol-
o ZyXEL GN650-T 64-bit PCI Gigabit Ethernet NIC (ZX1701)
o ZyXEL GN670-T 32-bit PCI Gigabit Ethernet NIC (ZX1702)
The VT6120/VT6122 is a 33/66MHz 64-bit PCI device which combines a tri-
speed MAC with an integrated 10/100/1000 copper PHY. (Some older cards
use an external PHY.) The VT6130/VT6132 is the PCI Express version. The
MAC supports IPv4 transmit/receive IP/TCP/UDP checksum offload, VLAN tag
insertion and stripping, a 64-entry CAM filter and a 64-entry VLAN fil-
ter, 64-bit multicast hash filter, 4 separate transmit DMA queues, flow
control and jumbo frames (not on VT6130/VT6132). The Velocity family has
a 16K receive FIFO and 48K transmit FIFO.
The vge driver takes advantage of the IPv4 transmit/receive IP/TCP/UDP
checksum offload, VLAN tag insertion and stripping, and the CAM filter
support. The CAM filter is used for multicast address filtering to pro-
vide 64 perfect multicast address filter support. If it is necessary for
the interface to join more than 64 multicast groups, the driver will
switch over to using the hash filter.
The vge driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to the appropriate hostname.if(5) file.
10baseT/UTP Set 10Mbps operation. The ifconfig(8) mediaopt option can
also be used to select either full-duplex or half-duplex
100baseTX Set 100Mbps (Fast Ethernet) operation. The ifconfig(8)
mediaopt option can also be used to select either
full-duplex or half-duplex modes.
1000baseT Set 1000baseT operation over twisted pair. Both full-duplex
and half-duplex modes are supported.
The vge driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
arp(4), ciphy(4), ifmedia(4), intro(4), ipgphy(4), netintro(4), pci(4),
The vge device driver first appeared in OpenBSD 3.7.
The vge driver was written by Bill Paul <firstname.lastname@example.org> and ported
to OpenBSD by Peter Valchev <email@example.com>.
BSD September 14, 2014 BSD