URNDIS(4) BSD Kernel Interfaces Manual URNDIS(4)
urndis -- USB Remote NDIS Ethernet device
urndis* at uhub?
The urndis driver provides Ethernet access over Remote NDIS (RNDIS),
allowing mobile devices such as phones and tablets to provide network
access. It is often referred to as USB tethering, and in most cases must
be explicitly enabled on the device.
urndis should work with any USB RNDIS devices, such as those commonly
found on Android devices. It does not support different media types or
options. For more information on configuring this device, see
arp(4), intro(4), netintro(4), usb(4), hostname.if(5), ifconfig(8)
The urndis device driver first appeared in OpenBSD 4.7.
The urndis driver was written by Jonathan Armani <firstname.lastname@example.org>,
Michael Knudsen <email@example.com>, and Fabien Romano <firstname.lastname@example.org>.
BSD July 16, 2013 BSD