updaters(4) File Formats updaters(4)
updaters - configuration file for NIS updating
The file /var/yp/updaters is a makefile (see make(1S)) which is used
for updating the Network Information Service (NIS) databases. Databases
can only be updated in a secure network, that is, one that has a pub-
lickey(4) database. Each entry in the file is a make target for a par-
ticular NIS database. For example, if there is an NIS database named
passwd.byname that can be updated, there should be a make target named
passwd.byname in the updaters file with the command to update the file.
The information necessary to make the update is passed to the update
command through standard input. The information passed is described
below (all items are followed by a NEWLINE except for 4 and 6):
1. Network name of client wishing to make the update (a string).
2. Kind of update (an integer).
3. Number of bytes in key (an integer).
4. Actual bytes of key.
5. Number of bytes in data (an integer).
6. Actual bytes of data.
After receiving this information through standard input, the command
to update the particular database determines whether the user is
allowed to make the change. If not, it exits with the status
YPERR_ACCESS. If the user is allowed to make the change, the command
makes the change and exits with a status of zero. If there are any
errors that may prevent the updaters from making the change, it should
exit with the status that matches a valid NIS error code described in
/var/yp/updaters The makefile used for updating the NIS data-
make(1S), rpc.ypupdated(1M), publickey(4)
The Network Information Service (NIS) was formerly known as Sun Yellow
Pages (YP). The functionality of the two remains the same; only the
name has changed. The name Yellow Pages is a registered trademark in
the United Kingdom of British Telecommunications plc, and may not be
used without permission.
SunOS 5.10 24 Oct 1996 updaters(4)