UPD(4) BSD Kernel Interfaces Manual UPD(4)
upd -- USB Power Devices sensor
upd* at uhidev?
The upd driver exposes data from USB Power Devices (such as an UPS), as
hardware sensors via sysctl(3).
The following sensors are provided by the upd driver, which can be moni-
tored using sensorsd(8):
intro(4), uhidev(4), sensorsd(8), sysctl(8)
The upd driver first appeared in OpenBSD 5.6.
The upd driver was written by Andre de Oliveira.
BSD March 24, 2017 BSD