UMS(4) BSD Kernel Interfaces Manual UMS(4)
ums -- USB HID mouse, touchscreen and digitiser devices
ums* at uhidev?
wsmouse* at ums? mux 0
The ums driver provides support for USB HID mice, touchscreens and digi-
tisers. Access to these devices is through the wscons(4) driver.
If the touchscreen sensor is poorly aligned, then xtsscale(1) should be
used to provide calibration results to the ums driver.
xtsscale(1), uhidev(4), usb(4), wsmouse(4)
The ums driver first appeared in OpenBSD 2.8.
HID touchscreen and digitiser support was written by Robert Nagy and
Matthieu Herrb then later merged into the generic ums driver by Edd
Touchscreen and digitiser pressure sensitivity is not yet implemented.
BSD March 24, 2017 BSD