UMS(4) BSD Kernel Interfaces Manual UMS(4)
ums -- USB mouse driver
The ums driver provides support for mice that attach to the USB port.
Supported are mice with any number of buttons and mice with a wheel. usb
and one of uhci or ohci must be configured in the kernel as well.
The /dev/ums device presents the mouse as a sysmouse or mousesystems type
device. See moused for an explanation of these mouse types.
/dev/ums0 blocking device node
Add the ums driver to the kernel.
moused -p /dev/ums0 -t auto
Use the first USB mouse on the system as your console mouse.
Change the "Pointer" section in xorg.conf to the following
to be able to use the USB mouse under X. When using the XiG accelerated
X server, change the mouse device to /dev/ums0 and the mouse type to
If you want to be able to use the mouse in both virtual consoles as well
as in X change it to:
ohci(4), sysmouse(4), uhci(4), usb(4), xorg.conf(5), moused(8)
The ums driver was written by Lennart Augustsson
<augustssATcs.se> for NetBSD and was adopted for FreeBSD by
MAEKAWA Masahide <bishopATrr.jp>.
This manual page was written by Nick Hibma <n_hibmaATFreeBSD.org> with
input from Kazutaka YOKOTA <yokotaATzodiac.jp>.
BSD February 5, 2005 BSD