UMODEM(4) BSD Kernel Interfaces Manual UMODEM(4)
umodem -- USB modem support
The umodem driver provides support for USB modems in the Communication
Device Class using the Abstract Control Model. These modems are basi-
cally standard serial line modems, but they are accessed via USB instead.
They support a regular AT command set. The commands can either be multi-
plexed with the data stream or handled through separate pipes. In the
latter case the AT commands have to be given on a device separate from
the data device.
The device is accessed through the ucom(4) driver which makes it behave
like a tty(4).
Devices supported by the umodem driver include:
o 3Com 5605
o Metricom Ricochet GS USB wireless modem
o Yamaha Broadband Wireless Router RTW65b
tty(4), ucom(4), usb(4)
The umodem driver appeared in NetBSD 1.5. This manual page was adopted
from NetBSD by Tom Rhodes <trhodesATFreeBSD.org> in April 2002.
Only modems with multiplexed commands and data are supported at the
BSD August 19, 2004 BSD