UMCT(4) BSD Kernel Interfaces Manual UMCT(4)
umct -- Magic Control Technology USB-RS232 converter driver
The umct driver provides support for USB to RS-232 converters based on
the Magic Control Technology USB-232 design. These devices support most
of the standard RS-232 features including baud rates ranging from 300 to
115200 bits per second. However, neither hardware nor software flow con-
trol seems to be supported.
Access to devices under this driver is via the ucom(4) framework and
The umct driver supports the following adapters:
o Belkin F5U109
o Belkin F5U409
o D-Link DU-H3SP USB BAY Hub
o Magic Control Technology USB-232
o Sitecom USB-232
tty(4), ucom(4), usb(4)
The umct driver appeared in FreeBSD 5.2. It is loosely based on the
ubsa(4) driver by Alexander Kabaev <kanATFreeBSD.org> with documentation
from Wolfgang Grandeggar <wolfgangATcec.ch>.
The umct driver was written by Scott Long <scottlATFreeBSD.org>.
BSD February 29, 2004 BSD