UMBG(4) BSD Kernel Interfaces Manual UMBG(4)
umbg -- Meinberg Funkuhren USB5131 timedelta sensor
umbg* at uhub?
The umbg driver provides support for the Meinberg Funkuhren USB5131, a
time signal station receiver for the German DCF77 station. umbg imple-
ments a timedelta sensor and the delta (in nanoseconds) between the
received time information and the local time can be accessed through the
The quality of the timedelta is reported as the sensor status:
UNKNOWN No valid time information has been received yet.
OK The time information is valid and the timedelta is safe
to use for applications like ntpd(8).
WARN The time information is still valid, but no new time
information has been decoded for at least twelve hours
due to a reception or parity error. The timedelta
should be used with care.
CRITICAL No valid time information has been received for more
than twelve hours since the sensor state degraded from
OK to WARN. This is an indication that hardware should
be checked to see if it is still functional.
A second sensor provides the relative signal quality as a percentage.
The status of this sensor is used to report the status of the device
OK The clock is synchronized.
WARN The device's clock is free running on the local oscil-
lator. This is not an error and can happen due to the
nature of the signal transmission using longwave radio.
CRITICAL Hardware failure, e.g. communication with the device
intro(4), usb(4), ntpd(8), sysctl(8)
The umbg driver first appeared in OpenBSD 4.3.
The umbg driver was written by Marc Balmer <firstname.lastname@example.org>.
BSD May 27, 2017 BSD