ULPT(4) BSD Kernel Interfaces Manual ULPT(4)
ulpt -- USB printer support
ulpt* at uhub?
The ulpt driver provides support for USB printers that follow the printer
bi- or uni-directional protocol. The bits in the minor number select
various features of the driver.
Minor Bit Function
64 Do not initialize the device on the port.
For some HP LaserJet printer models (1000, 1005, 1018, 1020), the driver
needs at least version 1.0 of the following firmware files, which are
loaded when a printer is attached:
These firmware files are not free because HP refuses to grant distribu-
tion rights. As a result, even though OpenBSD includes the driver, the
firmware files cannot be included and users have to download these files
on their own. A port which can download and install the firmware can be
found in /usr/ports/sysutils/firmware/ulpt.
intro(4), lpt(4), uhub(4), usb(4)
The ulpt driver appeared in NetBSD 1.4. OpenBSD support was added in
BSD February 4, 2013 BSD