ULPT(4) BSD Kernel Interfaces Manual ULPT(4)
ulpt -- USB printer support
The ulpt driver provides support for USB printers that follow the printer
bi- or uni-directional protocol. The bits in the minor number select
various features of the driver.
Minor Bit Function
64 Do not initialize (reset) the device on the port.
Some printers cannot handle the reset on open; in case of problems try
the unlpt device.
The ulpt driver provides support for USB printers and parallel printer
conversion cables, including the following:
o ATen parallel printer adapter
o Belkin F5U002 parallel printer adapter
o Canon BJ F850, S600
o Canon LBP-1310, 350
o Entrega USB-to-parallel printer adapter
o Hewlett-Packard HP Deskjet 3420 (P/N: C8947A #ABJ)
o Oki Data MICROLINE ML660PS
o Seiko Epson PM-900C, 880C, 820C, 730C
/dev/ulpt? device with reset
/dev/unlpt? device without reset
The ulpt driver appeared in NetBSD 1.4. This manual page was adopted
from NetBSD by Tom Rhodes <trhodesATFreeBSD.org> in April 2002.
BSD September 26, 2004 BSD