UHIDEV(4) BSD Kernel Interfaces Manual UHIDEV(4)
uhidev -- USB Human Interface Device support
uhidev* at uhub?
ubcmtp* at uhidev?
ucycom* at uhidev?
ugold* at uhidev?
uhid* at uhidev?
ukbd* at uhidev?
ums* at uhidev?
uoaklux* at uhidev?
uoakrh* at uhidev?
uoakv* at uhidev?
upd* at uhidev?
uslhcom* at uhidev?
uthum* at uhidev?
utpms* at uhidev?
utrh* at uhidev?
utwitch* at uhidev?
The uhidev driver handles all Human Interface Devices. Each HID device
can have several components, e.g., a keyboard and a mouse. These compo-
nents use different report identifiers (a byte) to distinguish which one
data is coming from. The uhidev driver has other drivers attached that
handle particular kinds of devices and uhidev only dispatches data to
them based on the report id.
intro(4), ubcmtp(4), ucycom(4), ugold(4), uhid(4), ukbd(4), ums(4),
uoaklux(4), uoakrh(4), uoakv(4), upd(4), usb(4), uslhcom(4), uthum(4),
utpms(4), utrh(4), utwitch(4)
The uhidev driver appeared in OpenBSD 3.2.
BSD April 27, 2017 BSD