UDCF(4) BSD Kernel Interfaces Manual UDCF(4)
udcf -- Gude ADS Expert mouseCLOCK USB timedelta sensor
udcf* at uhub?
The udcf driver provides support for the Gude ADS Expert mouseCLOCK USB
and the Expert mouseCLOCK USB II, receivers for the German DCF77 and the
Swiss HBG time signal stations. While receivers for the British MSF time
signal station are also being made, udcf lacks support for them.
udcf implements a timedelta sensor and the delta (in nanoseconds) between
the received time information and the local time can be accessed through
the sysctl(8) interface. The clock type is indicated in the sensor
DCF77 German DCF77 time signal station (77.5 kHz longwave
transmitter located in Mainflingen near Frankfurt).
HBG Swiss HBG time signal station (75 kHz longwave trans-
mitter located in Prangins near Geneva).
Unknown The clock type has not been determined.
The quality of the timedelta is reported as the sensor status:
UNKNOWN No valid time information has been received yet.
OK The time information is valid and the timedelta is safe
to use for applications like ntpd(8).
WARN The time information is still valid, but no new time
information has been decoded for at least 5 minutes due
to a reception or parity error. The timedelta should
be used with care.
CRITICAL No valid time information has been received for more
than 15 minutes since the sensor state degraded from OK
to WARN. This is an indication that hardware should be
checked to see if it is still functional. The
timedelta will eventually degrade to a lie as all com-
puter internal clocks have a drift.
intro(4), uhub(4), usb(4), ntpd(8), sysctl(8)
The udcf driver first appeared in OpenBSD 4.0.
The udcf driver was written by Marc Balmer <firstname.lastname@example.org>.
DCF77 uses a 77.5 kHz long wave radio signal transmitted from near Frank-
furt, Germany. Up to about 900 km, the radio signal can travel directly
to the receiver, providing a linearly increasing time offset based on
distance. Due to the curvature of the Earth, beyond this distance the
signal must bounce off the lower ionosphere (residing at approximately 70
km elevation during the day, and 90 km at night), thus causing a non-lin-
early increasing time offset which can only be roughly calculated using
trigonometry. Since the distance and transmission geometry is not known,
the clock receivers and udcf driver currently make no effort to calculate
this offset. We simply assume that the offset is small.
In Germany, the train system uses DCF77 clocks. As the distance from
Frankfurt increases, trains can be expected to run later.
BSD April 29, 2017 BSD