UBTBCMFW(4) BSD Kernel Interfaces Manual UBTBCMFW(4)
ubtbcmfw -- Firmware driver for Broadcom BCM2033 chip based Bluetooth USB
The ubtbcmfw is a firmware driver for Broadcom BCM2033 chip based Blue-
tooth USB devices. It provides minimal access to the parts of the device
required to download firmware.
The ubtbcmfw driver creates three fixed endpoint device nodes.
The control transfers can only happen on the control endpoint which is
always endpoint 0. Control requests are issued by ioctl(2) calls.
Only incoming transfers are supported on an interrupt endpoint. To per-
form I/O on an interrupt endpoint, read(2) should be used. All I/O oper-
ations on an interrupt endpoint are unbuffered. Interrupt endpoint is
always endpoint 1.
Only outgoing bulk transfers are supported on a bulk endpoint. To per-
form I/O on a bulk endpoint, write(2) should be used. All I/O operations
on a bulk endpoint are unbuffered. Outgoing bulk endpoint is always
The control endpoint (endpoint 0) handles the following ioctl(2) calls:
Return the device descriptor.
Most likely. Please report if found.
/dev/ubtbcmfwN.EE Endpoint EE of device N.
ng_ubt(4), ugen(4), usb(4), bcmfw(8)
The ubtbcmfw driver was implemented in FreeBSD 5.0.
Maksim Yevmenkin <m_evmenkinATyahoo.com>
BSD April 28, 2003 BSD