ttydefs(4) File Formats ttydefs(4)
ttydefs - file contains terminal line settings information for ttymon
/etc/ttydefs is an administrative file that contains records divided
into fields by colons (":"). This information used by ttymon to set
up the speed and terminal settings for a TTY port.
The ttydefs file contains the following fields:
ttylabel The string ttymon tries to match against the TTY port's
ttylabel field in the port monitor administrative file.
It often describes the speed at which the terminal is
supposed to run, for example, 1200.
initial-flags Contains the initial termio(7I) settings to which the
terminal is to be set. For example, the system adminis-
trator will be able to specify what the default erase
and kill characters will be. initial-flags must be
specified in the syntax recognized by the stty command.
final-flags final-flags must be specified in the same format as
initial-flags. ttymon sets these final settings after a
connection request has been made and immediately prior
to invoking a port's service.
autobaud If the autobaud field contains the character 'A,' auto-
baud will be enabled. Otherwise, autobaud will be dis-
abled. ttymon determines what line speed to set the TTY
port to by analyzing the carriage returns entered. If
autobaud has been disabled, the hunt sequence is used
for baud rate determination.
nextlabel If the user indicates that the current terminal setting
is not appropriate by sending a BREAK, ttymon searchs
for a ttydefs entry whose ttylabel field matches the
nextlabel field. If a match is found, ttymon uses that
field as its ttylabel field. A series of speeds is
often linked together in this way into a closed set
called a hunt sequence. For example, 4800 may be linked
to 1200, which in turn is linked to 2400, which is
finally linked to 4800.
sttydefs(1M), ttymon(1M), termio(7I)
System Administration Guide: Basic Administration
SunOS 5.10 27 Jan 1994 ttydefs(4)