TSL(4) BSD Kernel Interfaces Manual TSL(4)
tsl -- TAOS TSL2560/61 light sensor
tsl* at iic?
The tsl driver provides support for the TAOS TSL2560/61 light-to-digital
converters that transform light intensity into a digital signal output.
These sensors contain a broadband photodiode and an infrared-responding
photodiode allowing the ambient light level to be determined, as experi-
enced by the human eye. This illuminace (in lux) is made available
through the sysctl(8) interface and can, for example, be used to adjust
the backlight of LCD screens to lighting conditions.
iic(4), intro(4), sensorsd(8), sysctl(8)
The tsl driver first appeared in OpenBSD 3.9.
The tsl driver was written by Mark Kettenis <firstname.lastname@example.org>.
BSD July 16, 2013 BSD