TL(4) BSD Kernel Interfaces Manual TL(4)
tl -- Texas Instruments ThunderLAN 10/100 Ethernet device
tl* at pci?
lxtphy* at mii?
mlphy* at mii?
nsphy* at mii?
tlphy* at mii?
The tl driver provides support for PCI Ethernet adapters based on the
Texas Instruments ThunderLAN Ethernet controller chip. This includes a
large number of Compaq PCI-bus Ethernet adapters as well as the inte-
grated Ethernet controllers built in to several models of Compaq Prosig-
nia servers and Compaq Deskpro desktop machines. This driver also sup-
ports the Olicom OC-2135/2138, OC-2325 and OC-2326 10/100 TX UTP adapters
and the Racore 8165 10/100baseTX and 8148 10baseT/100baseTX/100baseFX
The ThunderLAN controller has a standard MII interface that supports up
to 32 physical interface devices (PHYs). It also has a built-in 10baseT
PHY hardwired at MII address 31, which may be used in some 10Mbps-only
hardware configurations. In 100Mbps configurations, a National Semicon-
ductor DP83840A or other MII-compliant PHY may be attached to the Thun-
derLAN's MII bus. If a DP83840A or equivalent is available, the Thunder-
LAN chip can operate at either 100Mbps or 10Mbps in either half-duplex or
full-duplex modes. The ThunderLAN's built-in PHY and the DP83840A also
The tl driver supports the following media types:
autoselect Enable autoselection of the media type and options. Note
that this option is only available on those PHYs that sup-
port autonegotiation. Also, the PHY will not advertise
those modes that have been explicitly disabled using the
following media options.
10baseT Set 10Mbps operation.
100baseTX Set 100Mbps (Fast Ethernet) operation.
10base5 Enable AUI/BNC interface (useful only with the built-in
The tl driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
hw-loopback Enable hardware loopback mode.
Note that the 100baseTX media type is only available if supported by the
PHY. For more information on configuring this device, see ifconfig(8).
tl0: couldn't map memory A fatal initialization error has occurred.
tl0: couldn't map interrupt A fatal initialization error has occurred.
tl0: device timeout The device has stopped responding to the network, or
there is a problem with the network connection (cable).
tl0: no memory for rx list The driver failed to allocate an mbuf for the
tl0: no memory for tx list The driver failed to allocate an mbuf for the
transmitter ring when allocating a pad buffer or collapsing an mbuf chain
into a cluster.
arp(4), ifmedia(4), intro(4), lxtphy(4), mlphy(4), netintro(4), nsphy(4),
pci(4), tlphy(4), hostname.if(5), ifconfig(8)
The tl device driver first appeared in FreeBSD 2.2. OpenBSD support
first appeared in OpenBSD 2.4.
The tl driver was written by Bill Paul <firstname.lastname@example.org>.
BSD April 29, 2017 BSD