TI(4) BSD Kernel Interfaces Manual TI(4)
ti -- Alteon Networks Tigon I and II Gigabit Ethernet device
ti* at pci?
ti* at sbus?
The ti driver provides support for Gigabit Ethernet adapters based on the
Alteon Networks Tigon Gigabit Ethernet controller chip, including the
o 3Com 3C985-SX Gigabit Ethernet (1000baseSX)
o 3Com 3C985B-SX Gigabit Ethernet (1000baseSX)
o Alteon AceNIC V Gigabit Ethernet (1000baseSX)
o Alteon AceNIC V Gigabit Ethernet (1000baseT)
o Digital EtherWORKS 1000SX PCI Gigabit Ethernet (1000baseSX)
o Farallon PN9000SX Gigabit Ethernet (1000baseSX)
o Netgear GA620 Gigabit Ethernet (1000baseSX)
o Netgear GA620T Gigabit Ethernet (1000baseT)
o Silicon Graphics Gigabit Ethernet (1000baseSX)
o Silicon Graphics Gigabit Ethernet (1000baseT)
o Sun Vector Gigabit Ethernet (1000baseSX)
The Tigon contains an embedded R4000 CPU, Gigabit MAC, dual DMA channels
and a PCI interface unit. The Tigon II contains two R4000 CPUs and other
refinements. Either chip can be used in either a 32-bit or 64-bit PCI
slot. Communication with the chip is achieved via PCI shared memory and
bus master DMA. SBus cards are also available and use a special bridge
chip. The Tigon I and II support hardware multicast address filtering,
VLAN tag insertion and stripping, and jumbo frames.
While the Tigon chipset supports 10, 100 and 1000Mbps speeds, support for
10 and 100Mbps speeds is only available on boards with the proper trans-
ceivers. Most adapters are only designed to work at 1000Mbps, however
the driver should support those NICs that work at lower speeds as well.
The ti driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to the appropriate hostname.if(5) file.
10baseT Set 10Mbps operation The mediaopt option can also be used to
select either full-duplex or half-duplex modes.
100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option
can also be used to select either full-duplex or half-duplex
1000baseSX Set 1000Mbps (Gigabit Ethernet) on fiber operation. Only
full-duplex mode is supported at this speed.
1000baseT Set 1000Mbps (Gigabit Ethernet) on copper operation.
The ti driver supports the following media options:
full-duplex Force full duplex operation
half-duplex Force half duplex operation
For more information on configuring this device, see ifconfig(8).
Two firmware files are necessary, for Tigon 1 and Tigon 2 devices. These
are loaded on demand when the device is attached:
ti0: couldn't map memory A fatal initialization error has occurred.
ti0: couldn't map interrupt A fatal initialization error has occurred.
ti0: no memory for softc struct! The driver failed to allocate memory
for per-device instance information during initialization.
ti0: failed to enable memory mapping! The driver failed to initialize
PCI shared memory mapping. This might happen if the card is not in a
ti0: no memory for jumbo buffers! The driver failed to allocate memory
for jumbo frames during initialization.
ti0: bios thinks we're in a 64 bit slot, but we aren't The BIOS has pro-
grammed the NIC as though it had been installed in a 64-bit PCI slot, but
in fact the NIC is in a 32-bit slot. This happens as a result of a bug
in some BIOSes. This can be worked around on the Tigon II, but on the
Tigon I initialization will fail.
ti0: board self-diagnostics failed! The ROMFAIL bit in the CPU state
register was set after system startup, indicating that the on-board NIC
ti0: unknown hwrev The driver detected a board with an unsupported hard-
ware revision. The ti driver supports revision 4 (Tigon 1) and revision
6 (Tigon 2) chips and has firmware only for those devices.
ti0: watchdog timeout -- resetting The device has stopped responding to
the network, or there is a problem with the network connection (cable).
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), sbus(4),
The ti device driver first appeared in FreeBSD 3.0. OpenBSD support
first appeared in OpenBSD 2.6. SBus support was added in OpenBSD 4.7.
The ti driver was written by Bill Paul <firstname.lastname@example.org>. SBus support
was added by Mark Kettenis <email@example.com>.
BSD September 14, 2014 BSD