THT(4) BSD Kernel Interfaces Manual THT(4)
tht, thtc -- Tehuti Networks 10Gb Ethernet device
thtc* at pci?
tht* at thtc?
The tht driver provides support for the Tehuti Networks 10 Gigabit Ether-
net controllers and adapters, including the following:
o TN3017-S 10 GbE Single Port XAUI Server Controller
o TN3017-D 10 GbE Dual Port XAUI Server Controller
o TN7581-D 10 GbE Dual XFP Server Adapter
o TN7585-D 10 GbE Dual CX4 Low Profile Server Adapter
o TN7588-S 10 GbE Single 10GBASET Low Profile Server Adapter
o TN7588-D 10 GbE Dual 10GBASET Low Profile Server Adapter
o TN7589-S 10 GbE Single CX4 Low Profile Server Adapter
The adapter needs a firmware file, which is loaded on demand by the
driver when the device is attached:
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), ifconfig(8)
The tht driver first appeared in OpenBSD 4.2.
The tht driver was written by David Gwynne <firstname.lastname@example.org>.
BSD July 16, 2013 BSD