telnetrc(4) File Formats telnetrc(4)
telnetrc - file for telnet default options
The .telnetrc file contains commands that are executed when a connec-
tion is established on a per-host basis. Each line in the file contains
a host name, one or more spaces or tabs, and a telnet(1) command. The
host name, DEFAULT, matches all hosts. Lines beginning with the pound
sign (#) are interpreted as comments and therefore ignored. telnet(1)
commands are case-insensitive to the contents of the .telnetrc file.
The .telnetrc file is retrieved from each user's HOME directory.
Example 1: A sample file.
In the following example, a .telnetrc file executes the telnet(1) com-
weirdhost toggle crmod
# Always export $PRINTER
DEFAULT environ export PRINTER
The lines in this file indicate that the toggle argument crmod, whose
default value is "off" (or FALSE), should be enabled when connecting to
the system weirdhost. In addition, the value of the environment vari-
able PRINTER should be exported to all systems. In this case, the
DEFAULT keyword is used in place of the host name.
telnet(1), in.telnetd(1M), environ(5)
SunOS 5.10 9 Jan 1998 telnetrc(4)