SWWDOG(4) Kernel Interfaces Manual SWWDOG(4)
swwdog -- software watchdog timer
The swwdog driver provides a software watchdog timer that works with
wdogctl(8). If the timer expires, the system reboots if the boolean
variable swwdog_reboot is true; otherwise, the system will panic.
swwdog_reboot is accessible as a sysctl(8) variable, hw.swwdog.reboot and
defaults to false.
The default period of swwdog is 60 seconds.
As with other watchdog timers, the swwdog driver prevents a system from
suspending when the watchdog is armed.
The swwdog driver was written by Steven M. Bellovin.
Only one watchdog timer can be active at any given time. (Arguably, this
is a bug in the watchdog timer framework.) Therefore, only a single
instance of the swwdog device can be created.
Kernel tickle mode is useless with swwdog and arguably should be
rejected, since both it and this driver rely on the same callout
mechanism; if one is blocked, almost certainly the other is as well.
The alarm option to wdogctl(8) isn't implemented.
NetBSD 6.1.5 June 8, 2011 NetBSD 6.1.5