SV(4) BSD Kernel Interfaces Manual SV(4)
sv -- S3 SonicVibes audio device
sv* at pci?
audio* at sv?
The sv driver provides support for S3 SonicVibes (S3-617) chipset-based
cards. Disabling the SRS 3-D spatial feature of the chip is recommended
for higher quality audio. This can be done in software by issuing the
$ mixerctl outputs.spatial=off
audio(4), intro(4), pci(4)
This driver is based on the eap(4) driver by Lennart Augustsson. The sv
device driver first appeared in OpenBSD 2.6.
The "FM" DAC, wavetable synth, and MIDI port are not supported. Record-
ing at a rate different from playback is supported by the chip but not
the driver. The mixer does not allow control of reverb, digital loop-
back, or 3-D SRS features. The chip does not support exact record speeds
(it seems) of 11025Hz, 22050Hz, and so on, used by Windows audio. Usu-
ally, the actual record is rate is around +/- 50Hz of the specified.
BSD April 27, 2017 BSD