STUIRDA(4) Kernel Interfaces Manual STUIRDA(4)
stuirda -- Sigmaltel 4116/4220 USB-IrDA bridge support
stuirda* at uhub?
irframe* at uirda?
The stuirda driver provides support for SigmaTels USB-IrDA bridges that
nearly follow the bridge specification:
Access to the IrDA device is through the irframe(4) driver. Before
accessing it, a firmware patch must be downloaded. At the time of
writing this, it can be found at:
Unpack the archive with
tar -C /libdata/firmware/stuirda/ -xzf
The stuirda driver appeared in NetBSD 5.0.
stuirda needs the firmware for configuration, so it can't be loaded at
kernel startup time. As a workaround, you can plug in the USB-IrDA-
bridge after booting.
NetBSD 6.1.5 October 13, 2008 NetBSD 6.1.5