STE(4) BSD Kernel Interfaces Manual STE(4)
ste -- Sundance Technologies ST201 10/100 Ethernet device
ste* at pci?
The ste driver provides support for PCI Ethernet adapters and embedded
controllers based on the Sundance Technologies ST201 PCI Fast Ethernet
controller chip. This includes:
o D-Link DFE-550TX
o D-Link DFE-580TX
o Encore ENL832-TX-ICNT 10/100 M PCI
The Sundance ST201 uses bus master DMA and is designed to be a 3Com
EtherLink XL work-alike. It uses the same DMA descriptor structure and
is very similar in operation, however its register layout is different.
The ST201 has a 64-bit multicast hash filter and a single perfect filter
entry for the station address. It supports both 10 and 100Mbps speeds in
either full or half duplex using an MII transceiver.
The ste driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to the hostname.if(5) file.
10baseT Set 10Mbps operation. The mediaopt option can also be used
to select either full-duplex or half-duplex modes.
100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option
can also be used to select either full-duplex or half-duplex
The ste driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
ste0: couldn't map ports/memory A fatal initialization error has
ste0: couldn't map interrupt A fatal initialization error has occurred.
ste0: watchdog timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
ste0: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
ste0: no memory for tx list The driver failed to allocate an mbuf for
the transmitter ring when allocating a pad buffer or collapsing an mbuf
chain into a cluster.
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), hostname.if(5),
Sundance ST201 data sheet, http://www.sundanceti.com.
The ste device driver first appeared in FreeBSD 3.0. OpenBSD support was
added in OpenBSD 2.7.
The ste driver was written by Bill Paul <firstname.lastname@example.org> and
ported to OpenBSD by Aaron Campbell <email@example.com>.
BSD July 16, 2013 BSD