SNP(4) BSD Kernel Interfaces Manual SNP(4)
snp -- tty snoop interface
ioctl(fd, SNPSTTY, &dev);
ioctl(fd, SNPGTTY, &dev);
ioctl(fd, FIONREAD, &result);
/dev/snp? are snoop devices which allow users to attach to any tty and
watch activities on it. The kernel must be compiled with device snp, or
the snp module must be loaded, for these devices to be available.
To associate a given snp device with a tty to be observed, open the snp
device and then use the SNPSTTY ioctl. The argument passed to the
ioctl(2) is the address of a variable of type udev_t. To detach the snp
device from a tty use a pointer to a value of NODEV.
The SNPGTTY ioctl returns information about the current tty attached to
the open snp device.
The FIONREAD ioctl returns a positive value equal to the number of char-
acters in a read buffer. Special values defined are:
SNP_OFLOW device overflow occurred, device detached.
SNP_TTYCLOSE tty not attached.
SNP_DETACH snp device has been detached by user or tty device has been
closed and detached.
pty(4), sio(4), kldload(8), watch(8)
Caveat emptor! This manual page is horribly stale and wildly inaccurate
in some places.
While in line mode, user input cannot be seen. No signals may be sent to
the observed tty.
Ugen J.S. Antsilevich <ugenATNetVision.il>
The snp device first appeared in FreeBSD 2.1.
BSD February 24, 1995 BSD