SND_MAESTRO3(4) BSD Kernel Interfaces Manual SND_MAESTRO3(4)
snd_maestro3 -- ESS Maestro3/Allegro-1 bridge device driver
The snd_maestro3 driver provides support for the ESS Maestro3 and Alle-
gro-1 sound chips under the PCM framework. These chips are mostly found
in laptop computers and feature an AC97 mixer, a multi-channel sample
rate converter that can mix up to four digital audio streams in hardware,
recording support, and external volume control buttons.
The firmware for the sound processor is licensed under the GNU Public
License, and thus this driver is not included in the default GENERIC ker-
nel. A convenient way to automatically load the driver is to add the
to the file /boot/loader.conf.
The snd_maestro3 driver supports the following audio devices:
o ESS Technology Allegro-1
o ESS Technology Maestro3
The hardware volume control buttons can be connected to two different pin
sets on the chip, depending on the manufacturer. The driver has no way
of determining this configuration, so a hint may be used to override the
default guess. Add the line ``hint.pcm.0.hwvol_config="0"'' to the file
/boot/device.hints to override the default setting.
The snd_maestro3 driver first appeared in FreeBSD 4.3.
Scott Long <scottlATFreeBSD.org>
Darrel Anderson <andersonATcs.edu>
BSD December 14, 2004 BSD