SN(4) Kernel Interfaces Manual SN(4)
sn -- National Semiconductor DP83932 (SONIC) based Ethernet device driver
sn0 at jazzio?
sn* at obio?
sn* at nubus?
The sn interface provides access to a 10 Mb/s Ethernet network via the
National Semiconductor DP83932 (SONIC) Ethernet chip set.
Each of the host's network addresses is specified at boot time with an
SIOCSIFADDR ioctl(2). The sn interface employs the address resolution
protocol described in arp(4) to dynamically map between Internet and
Ethernet addresses on the local network.
The sn driver supports on-board JAZZ based SONIC interfaces found on Acer
PICA and NEC machines.
The sn driver is currently known to support the following NuBus cards:
o Apple LC Twisted-pair (part #820-0532-A) PDS card
o Cayman Gatorcard PDS
o Dayna DaynaPort/E30
In addition, the sn interface supports the following interfaces:
o on-board Ethernet for non-AV Quadras
o on-board Ethernet for 500-series PowerBooks
o Apple CS Ethernet Twisted-pair card for Comm Slot found on
LC575, Quadra 630, LC630, and Performa 580.
sn%d: transmit FIFO underrun
sn%d: receive FIFO overrun
sn%d: receive buffer exceeded
sn%d: receive buffers exhausted
sn%d: receive descriptors exhausted These messages indicate that the
interface gets errors (due to heavy load etc.) and reinitialized.
arp(4), inet(4), netintro(4), ifconfig(8)
The sn interface for mac68k, which was derived from a driver for old
NetBSD/pica port, first appeared in NetBSD 1.3.
Jason Thorpe has rewritten a new machine independent SONIC driver which
uses bus_dma(9) and bus_space(9) APIs after NetBSD 1.5 release, and
NetBSD/arc has been switched to using the machine independent (MI)
NetBSD/mac68k has also been switched to using the MI driver after the
NetBSD 4.0 release.
NetBSD 6.1.5 May 16, 2009 NetBSD 6.1.5