SK(4) BSD Kernel Interfaces Manual SK(4)
sk, skc -- SysKonnect XMAC II and Marvell Yukon 10/100/Gigabit Ethernet
skc* at pci?
sk* at skc?
brgphy* at mii?
eephy* at mii?
xmphy* at mii?
The sk driver provides support for SysKonnect GEnesis and Marvell Yukon
88E8001, 88E8003 and 88E8010 based Gigabit Ethernet adapters, including
o 3Com 3c940 single port, copper adapter
o 3Com 3c2000-T single port, copper adapter
o Allied Telesis AT-2916T, copper adapter
o Belkin F5D5005 v1000, copper adapter
o D-Link DGE-530T A1, copper adapter
o D-Link DGE-530T B1, copper adapter
o Fujitsu PP028GE1U, multimode fiber adapter
o Fujitsu PP028GE1X, multimode fiber adapter
o Fujitsu PW008GE1U, copper adapter
o Fujitsu PW008GE1X, copper adapter
o Linksys EG1032v2, copper adapter
o Linksys EG1064v2, copper adapter
o SMC 9452TX, copper adapter
o SysKonnect SK-9521 V2.0 single port, copper adapter
o SysKonnect SK-9821 single port, copper adapter
o SysKonnect SK-9821 V2.0 single port, copper adapter
o SysKonnect SK-9822 dual port, copper adapter
o SysKonnect SK-9841 single port, single mode fiber adapter
o SysKonnect SK-9842 dual port, single mode fiber adapter
o SysKonnect SK-9843 single port, multimode fiber adapter
o SysKonnect SK-9843 V2.0 single port, copper adapter
o SysKonnect SK-9844 dual port, multimode fiber adapter
The SysKonnect based adapters consist of two main components: the XaQti
Corp. XMAC II Gigabit MAC (sk) and the SysKonnect GEnesis controller ASIC
(skc). The XMAC provides the Gigabit MAC and PHY support while the GEne-
sis provides an interface to the PCI bus, DMA support, packet buffering
and arbitration. The GEnesis can control up to two XMACs simultaneously,
allowing dual-port NIC configurations.
The Marvell based adapters are a single integrated circuit, but are still
presented as a separate MAC (sk) and controller ASIC (skc).
The GEnesis and Yukon 88E8001, 88E8003 and 88E8010 also support jumbo
The sk driver supports the following media types:
autoselect Enable autoselection of the media type and options. The user
can manually override the autoselected mode by adding media
options to the appropriate hostname.if(5) file.
10baseT Set 10Mbps operation. The ifconfig(8) mediaopt option can
also be used to select either full-duplex or half-duplex
100baseTX Set 100Mbps (Fast Ethernet) operation. The ifconfig(8)
mediaopt option can also be used to select either full-duplex
or half-duplex modes.
1000baseT Set 1000baseT (Gigabit Ethernet) operation over twisted pair.
Both full-duplex and half-duplex modes are supported.
1000baseSX Set 1000Mbps (Gigabit Ethernet) operation. Both full-duplex
and half-duplex modes are supported.
The sk driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8). To
view a list of media types and options supported by the card, try
ifconfig <<device>> media. For example, ifconfig sk0 media.
arp(4), brgphy(4), eephy(4), ifmedia(4), intro(4), netintro(4), pci(4),
xmphy(4), hostname.if(5), ifconfig(8)
XaQti XMAC II datasheet.
SysKonnect GEnesis programming manual, http://www.syskonnect.com.
The sk device driver first appeared in FreeBSD 3.0, and OpenBSD support
was added in OpenBSD 2.6.
The sk driver was written by Bill Paul <firstname.lastname@example.org>.
BSD March 30, 2017 BSD