SIS(4) BSD Kernel Interfaces Manual SIS(4)
sis -- SiS 900, SiS 7016, and NS DP83815/6 10/100 Ethernet device
sis* at pci?
icsphy* at mii?
nsphyter* at mii?
rlphy* at mii?
The sis driver provides support for PCI Ethernet adapters and embedded
controllers based on the Silicon Integrated Systems SiS 900 / SiS 7016
Fast Ethernet controller chips, and National Semiconductor DP83815 (Mac-
PHYTER) / DP83816 (MacPHYTER-II) PCI Ethernet controller chips, including
o @Nifty FNECHARD IFC USUP-TX
o MELCO LGY-PCI-TXC
o Netgear FA311, FA312, FA331
o Soekris Engineering lan1621, lan1641
The SiS 900 is a 100Mbps Ethernet MAC and MII-compliant transceiver in a
single package. It uses a bus master DMA and a scatter/gather descriptor
scheme. The SiS 7016 is similar to the SiS 900 except that it has no
internal PHY, requiring instead an external transceiver to be attached to
its MII interface. The SiS 900 and SiS 7016 both have a 128-bit multi-
cast hash filter and a single perfect filter entry for the station
The NS DP83815 and DP83816 are also 100Mbps Ethernet MACs with integrated
PHY. The NatSemi chips and the SiS chips share many of the same features
and a fairly similar programming interface, and hence are supported by
the same driver.
The sis driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to the hostname.if(5) file.
10baseT Set 10Mbps operation. The mediaopt option can also be used
to select either full-duplex or half-duplex modes.
100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option
can also be used to select either full-duplex or half-duplex
The sis driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
sis0: couldn't map ports/memory A fatal initialization error has
sis0: couldn't map interrupt A fatal initialization error has occurred.
sis0: watchdog timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
sis0: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
sis0: no memory for tx list The driver failed to allocate an mbuf for
the transmitter ring when allocating a pad buffer or collapsing an mbuf
chain into a cluster.
arp(4), icsphy(4), ifmedia(4), intro(4), netintro(4), nsphyter(4),
pci(4), rlphy(4), hostname.if(5), ifconfig(8)
SiS 900 and SiS 7016 datasheets, http://www.sis.com.tw.
NatSemi DP83815 and DP83816 datasheets, http://www.national.com.
The sis device driver first appeared in FreeBSD 3.0. OpenBSD support was
added in OpenBSD 2.7.
The sis driver was written by Bill Paul <firstname.lastname@example.org> and
ported to OpenBSD by Aaron Campbell <email@example.com>.
BSD August 14, 2013 BSD