shells(4) File Formats shells(4)
shells - shell database
The shells file contains a list of the shells on the system. Applica-
tions use this file to determine whether a shell is valid. See getuser-
shell(3C). For each shell a single line should be present, consisting
of the shell's path, relative to root.
A hash mark (#) indicates the beginning of a comment; subsequent char-
acters up to the end of the line are not interpreted by the routines
which search the file. Blank lines are also ignored.
The following default shells are used by utilities: /bin/bash,
/bin/csh, /bin/jsh, /bin/ksh, /bin/pfcsh, /bin/pfksh, /bin/pfsh,
/bin/sh, /bin/tcsh, /bin/zsh, /sbin/jsh, /sbin/sh, /usr/bin/bash,
/usr/bin/csh, /usr/bin/jsh, /usr/bin/ksh, /usr/bin/pfcsh,
/usr/bin/pfksh, /usr/bin/pfsh, and /usr/bin/sh, /usr/bin/tcsh,
/usr/bin/zsh. Note that /etc/shells overrides the default list.
Invalid shells in /etc/shells may cause unexpected behavior (such as
being unable to log in by way of ftp(1)).
/etc/shells lists shells on system
vipw(1B), ftpd(1M), sendmail(1M), getusershell(3C), aliases(4)
SunOS 5.10 4 Jun 2001 shells(4)