SF(4) BSD Kernel Interfaces Manual SF(4)
sf -- Adaptec AIC-6915 Starfire PCI 10/100 Ethernet device
sf* at pci?
sqphy* at mii?
The sf driver provides support for Adaptec Duralink Fast Ethernet
adapters based on the Adaptec AIC-6915 "Starfire" chipset. This includes
o ANA-62011 64-bit single port 10/100baseTX
o ANA-62022 64-bit dual port 10/100baseTX
o ANA-62044 64-bit quad port 10/100baseTX
o ANA-69011 32-bit single port 10/100baseTX
o ANA-62020 64-bit single port 100baseFX
The AIC-6915 is a bus master controller with an MII interface. It sup-
ports high and low priority transmit and receive queues, TCP/IP checksum
offload, multiple DMA descriptor formats and both polling and pro-
ducer/consumer DMA models. The AIC-6915 receive filtering options
include a 16 entry perfect filter, a 512-bit hash table for multicast
addresses, a 512-bit hash table for priority address matching and VLAN
filtering. An external MII-compliant transceiver is required for media
Multiport adapters consist of several AIC-6915 controllers connected via
a PCI to PCI bridge. Each controller is treated as a separate interface
by the sf driver.
The sf driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to the hostname.if(5) file.
10baseT Set 10Mbps operation. The mediaopt option can also be used
to select either full-duplex or half-duplex modes.
100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option
can also be used to select either full-duplex or half-duplex
The sf driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), sqphy(4),
The Adaptec AIC-6915 Programmer's Manual,
The sf device driver first appeared in OpenBSD 2.7.
The sf driver was written by Jason R. Thorpe <thorpej@NetBSD.org> and
ported to OpenBSD by Martin Reindl <firstname.lastname@example.org>.
The sf driver does not support the IPv4/TCP/UDP checksum function of the
The sf driver does not support the VLAN function of the AIC-6915.
BSD July 16, 2013 BSD