SE(4) BSD Kernel Interfaces Manual SE(4)
se -- SiS 190/191 10/100/Gigabit Ethernet device
se* at pci?
atphy* at mii?
brgphy* at mii?
eephy* at mii?
etphy* at mii?
rlphy* at mii?
The se driver provides support for the SiS190 Fast Ethernet controller
integrated into the SiS965L and SiS966L southbridges, and the SiS191
Gigabit controller integrated into the SiS965 and SiS966 southbridges.
Both SiS 190 and SiS 191 embed an Ethernet MAC with external PHY. They
use a bus master DMA and a scatter/gather descriptor scheme and include a
64-bit multicast hash filter.
The se driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to the hostname.if(5) file.
10baseT Set 10Mbps operation. The mediaopt option can also be used
to select either full-duplex or half-duplex modes.
100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option
can also be used to select either full-duplex or half-duplex
1000baseSX Set 1000Mbps (Gigabit Ethernet) on fiber operation. Only
full-duplex mode is supported at this speed.
1000baseT Set 1000Mbps (Gigabit Ethernet) on copper operation.
The se driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
se0: EEPROM read timeout The driver could not read the controller's MAC
address from its EEPROM.
se0: invalid EEPROM signature The driver could not find the expected
EEPROM signature and could not read the controller's MAC address.
se0: Could not find PCI-ISA bridge The driver could not read the con-
troller's MAC address from the CMOS memory connected to the PCI-ISA
se0: PHY read timeout The driver could not read data from the PHY.
se0: PHY write timeout The driver could not write data to the PHY.
se0: watchdog timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
arp(4), atphy(4), brgphy(4), eephy(4), etphy(4), ifmedia(4), intro(4),
netintro(4), pci(4), rlphy(4), hostname.if(5), ifconfig(8)
The se driver first appeared in OpenBSD 4.8.
The se driver was adapted by Alexander Pohoyda
<firstname.lastname@example.org> from the sis(4) driver written by Bill Paul
<email@example.com>, and ported to OpenBSD by Christopher Zimmermann
<firstname.lastname@example.org>. SiS 191 support was added by Nikolay Denev
BSD April 27, 2017 BSD