SCHSIO(4) BSD Kernel Interfaces Manual SCHSIO(4)
schsio -- SMSC SCH311x LPC Super I/O
schsio* at isa? port 0x2e flags 0x0000
schsio* at isa? port 0x4e flags 0x0000
schsio* at isa? port 0x162e flags 0x0000
schsio* at isa? port 0x164e flags 0x0000
The schsio driver provides support for the SMSC SCH3112, SCH3114, and
SCH3116 ICs. Among other things, the devices contain environment sen-
sors, a watchdog timer, and fan control. The schsio driver supports the
environment sensors and the watchdog timer.
The hardware provides the following sensors:
Sensor Units Typical use
Internal diode uK IC internal thermal diode
Remote diode 1 uK External thermal diode
Remove diode 2 uK External thermal diode
FAN1 RPM Fan tachometer
FAN2 RPM Fan tachometer
FAN3 RPM Fan tachometer
+2.5V uV Voltage
+1.5V (Vccp) uV Voltage
+3.3V (VCC) uV Voltage
+5V uV Voltage
+12V uV Voltage
+3.3V (VTR) uV Voltage
+3V (Vbat) uV Voltage
schsio provides the standard watchdog(4) interface and may be used with
watchdogd(8). The watchdog timer may be configured to a value from 1
second to 255 minutes. The watchdog timer has a resolution of 1 second
in the timeout interval 1 to 255 seconds. Outside this interval, the
resolution is 1 minute.
Note that the pin used for signalling the timer expiration is config-
urable and may on some boards be intended for other uses than this.
Because of this, the chip may not by default be configured to use the pin
for watchdog operation. To force the schsio device to use the pin for
watchdog operation, the driver may be configured with an autoconf(9)
flags setting of 0x0001.
intro(4), isa(4), watchdog(4), sensorsd(8), sysctl(8), watchdogd(8),
The schsio driver first appeared in OpenBSD 4.5.
The schsio driver was written by Michael Knudsen <firstname.lastname@example.org>.
BSD July 16, 2013 BSD