SCHED_ULE(4) BSD Kernel Interfaces Manual SCHED_ULE(4)
sched_ule -- ULE Scheduler
sched_ule is an experimental scheduler that provides a number of advanced
scheduler features not present in sched_4bsd(4), the default system
scheduler. These features address SMP and interactivity and include:
o Thread CPU affinity.
o CPU topology awareness, including for hyper-threading.
o Per-CPU run queues.
o Interactivity heuristics that detect interactive applications
and schedules them preferentially under high load.
The following sysctls are relevant to the operation of sched_ule:
This read-only sysctl reports the name of the active scheduler.
sched_ule is disabled by default as it is experimental. See the bugs
section for more information.
The sched_ule scheduler first appeared in FreeBSD 5.1.
Jeff Roberson <jeffATFreeBSD.org>
As an experimental scheduler, sched_ule is not enabled by default due to
a number of known issues, including weak performance with several known
workloads, and reports of instability. Deployment of sched_ule in pro-
duction environments should be done cautiously.
BSD April 7, 2005 BSD