SBP_TARG(4) BSD Kernel Interfaces Manual SBP_TARG(4)
sbp_targ -- Serial Bus Protocol 2 (SBP-2) Target Mode devices driver
The sbp_targ driver provides support for SBP-2 target mode. This driver
is supposed to work with cam(4), targ(4) and firewire(4). You also need
to use scsi_target(8), which can be found in
/usr/share/examples/scsi_target, to provide actual devices.
# mdconfig -a -t malloc -s 10m
# scsi_target 0:0:0 /dev/md0
(Assuming sbp_targ0 on scbus0)
cam(4), firewire(4), targ(4), camcontrol(8), fwcontrol(8), kldload(8),
The sbp_targ driver was written by Hidetoshi Shimokawa.
This driver is currently under development. It does not work correctly
in multi-initiator environments or after the bus topology has been
BSD November 7, 2003 BSD