SAFTE(4) BSD Kernel Interfaces Manual SAFTE(4)
safte -- SCSI Accessed Fault-Tolerant Enclosure
safte* at scsibus?
The safte driver provides support for monitoring the various environmen-
tal sensors present in SCSI enclosures using the SCSI Accessed Fault-Tol-
erant Enclosure command set. The hardware monitor is used with the
SAF-TE compliant devices can provide an arbitrary set of sensors from the
Sensor Units Typical Use
temp uK temperature
fan RPM fan
psu On/Off power supply
doorlock On/Off door lock
alarm On/Off enclosure alarm
Sensor data is updated every 10 seconds.
An enclosure may provide environmental information using an alternative
to the SCSI Accessed Fault-Tolerant Enclosure command set used by this
driver. Enclosures using the SCSI Enclosure Services command set may be
monitored by the ses(4) driver.
intro(4), scsibus(4), ses(4), sensorsd(8), sysctl(8)
The safte driver first appeared in OpenBSD 3.8.
The safte driver was written by David Gwynne <firstname.lastname@example.org>.
BSD May 25, 2017 BSD