RTFPS(4) BSD Kernel Interfaces Manual RTFPS(4)
rtfps -- multiplexing serial communications interface
rtfps0 at isa? port 0x1230 irq 10
com* at rtfps?
The rtfps driver provides support for IBM RT PC boards that multiplex
together up to four EIA RS-232C (CCITT V.28) or RS-422A communications
Each rtfps device is the master device for up to four com devices. The
kernel configuration specifies these com devices as slave devices of the
rtfps device, as shown in SYNOPSIS. The port specification for the rtfps
device is used to compute the base addresses for the com subdevices.
com(4), intro(4), isa(4)
The rtfps driver was written by Charles Hannum, based on the ast driver.
The rtfps driver is unlikely to work on non-EISA and non-PCI machines.
The ISA bus only asserts 10 I/O address lines, and this is not enough.
Even on EISA and PCI machines, some address conflicts have been observed.
On one machine, the second port always conflicted with something (though
it's not clear what) and caused strange results. Disabling the second
port in the kernel config allowed the other three ports to function cor-
BSD February 20, 2014 BSD