RE(4) BSD Kernel Interfaces Manual RE(4)
re -- Realtek 8139C+/8169/816xS/811xS/8168/810xE 10/100/Gigabit Ethernet
re* at pci?
re* at cardbus?
eephy* at mii?
rgephy* at mii?
rlphy* at mii?
The re driver provides support for various NICs based on the Realtek
RTL8139C+, RTL8169, RTL816xS, RTL811xS, RTL8168 and RTL810xE PCI and PCI
Express Ethernet controllers, including the following:
o Alloy Computer Products EtherGOLD 1439E 10/100 (8139C+)
o Buffalo LGY-PCI-GT (8169S)
o Compaq Evo N1015v Integrated Ethernet (8139C+)
o Corega CG-LAPCIGT (8169S)
o D-Link DGE-528T (8169S)
o D-Link DGE-530T C1 (8169/8110SB)
o D-Link DGE-660TD (8169/8110SB)
o Gigabyte 7N400 Pro2 Integrated Gigabit Ethernet (8110S)
o LevelOne GNC-0105T (8169S)
o Linksys EG1032v3 (8169S)
o Netgear GA311 (8169S)
o Netgear GA511 PC Card (8169)
o PLANEX COMMUNICATIONS Inc. GN-1200TC (8169S)
o Surecom EP-320G-TX1 (8169S)
o TTTech MC322 (8139C+)
o US Robotics USR997902 (8169S)
o Xterasys XN-152 10/100/1000 NIC (8169)
NICs based on the 8139C+ and 810xE are capable of 10 and 100Mbps speeds
over CAT5 cable. NICs based on the 8169, 816xS, 811xS and 8168 are capa-
ble of 10, 100 and 1000Mbps operation.
All re NICs support IPv4 transmit/receive IP/TCP/UDP checksum offload,
VLAN tag insertion and stripping, and use a descriptor-based DMA mecha-
nism. The 8102E(L), 8103E(L), 8168C/8111C, 8168D/8111D, 8168DP/8111DP
and 8168E/8111E chips also support IPv6 receive TCP/UDP checksum offload.
The 8139C+ is a single-chip solution combining both a 10/100 MAC and PHY.
The 8169 is a 10/100/1000 MAC only, requiring a GMII or TBI external PHY.
The 8169S, 8110S, 8111B and 8168 are single-chip devices containing both
a 10/100/1000 MAC and 10/100/1000 copper PHY. Standalone 10/100/1000
cards are available in both 32-bit PCI and 64-bit PCI models. The 8110S
and 8111B are designed for embedded LAN-on-motherboard applications.
The 8169, 8169S and 8110S also support jumbo frames.
The re driver additionally supports Wake on LAN (WoL). See arp(8) and
ifconfig(8) for more details.
The re driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to the appropriate hostname.if(5) file.
10baseT/UTP Set 10Mbps operation. The ifconfig(8) mediaopt option can
also be used to select either full-duplex or half-duplex
100baseTX Set 100Mbps (Fast Ethernet) operation. The ifconfig(8)
mediaopt option can also be used to select either
full-duplex or half-duplex modes.
1000baseT Set 1000baseT operation over twisted pair. The Realtek GigE
chips support 1000Mbps in full-duplex mode only.
The re driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
arp(4), eephy(4), ifmedia(4), intro(4), netintro(4), pci(4), rgephy(4),
rlphy(4), hostname.if(5), ifconfig(8)
Realtek Semiconductor RTL8139C+, RTL8169, RTL8169S and RTL8110S
The re device driver first appeared in OpenBSD 3.6.
The re driver was written by Bill Paul <email@example.com> and ported
to OpenBSD by Peter Valchev <firstname.lastname@example.org>.
The Xterasys XN-152 32-bit PCI NIC, which uses the RTL8169 MAC and Mar-
vell 88E1000 PHY, has a defect that causes DMA corruption if the board is
plugged into a 64-bit PCI slot. The defect lies in the board design, not
the chip itself: the PCI REQ64# and ACK64# lines should be pulled high,
but they are not. The result is that the 8169 chip is tricked into per-
forming 64-bit DMA transfers even though a 64-bit data path between the
NIC and the bus does not actually exist.
Unfortunately, it is not possible to correct this problem in software.
The user should ensure the NIC is installed in a 32-bit PCI slot to avoid
BSD September 14, 2014 BSD