PUD(4) Kernel Interfaces Manual PUD(4)
pud -- Pass-to-Userspace Device
The pud driver enables the implementation of block and character device
drivers as userspace daemons. The daemons register the device major
number they wish to handle. Registering a character device is mandatory,
supporting the block device interface for same major device is optional.
The major number must be available, i.e. another driver must not be
registered to handle the operation. After successful registration the
userspace daemon is supposed to handle the driver methods the kernel
passes down to it.
This document is in a hit-in-the-head style obviously not even near
The subsystem lacks a puffs-style library that servers can be written
NetBSD 6.1.5 November 21, 2007 NetBSD 6.1.5