PIIXPM(4) BSD Kernel Interfaces Manual PIIXPM(4)
piixpm -- Intel PIIX SMBus controller
piixpm* at pci?
iic* at piixpm?
The piixpm driver provides support for the Intel PIIX and compatible
Power Management controller. Only the SMBus host interface is supported
and can be used with the iic(4) framework.
o AMD Hudson-2
o ATI SB200, SB300, SB400, SB600, SB700, SB800
o Intel 82371AB (PIIX4), 82440MX
o ServerWorks OSB4, CSB5, CSB6, HT-1000, HT-1100
o SMSC Victory66
iic(4), intro(4), pci(4)
The piixpm driver first appeared in OpenBSD 3.7 to provide support for
the power management (ACPI) timer. In OpenBSD 3.9, power management sup-
port was dropped in favor of acpitimer(4) and SMBus functionality was
The current piixpm driver was written by Alexander Yurchenko
The driver doesn't support I2C commands with a data buffer size of more
than 2 bytes.
BSD July 16, 2013 BSD