PGT(4) BSD Kernel Interfaces Manual PGT(4)
pgt -- Conexant/Intersil Prism GT Full-MAC IEEE 802.11a/b/g wireless net-
pgt* at cardbus?
pgt* at pci?
The pgt driver provides support for Conexant/Intersil GT-series devices
which can support the Full-Mac firmware, using the ISL3877, ISL3880, and
ISL3890 chips. The pgt driver will not (yet) work on similar devices
using the ISL3886 or similar chips which use the Soft-Mac firmware.
These are the modes the pgt driver can operate in:
BSS mode Also known as infrastructure mode, this is used when asso-
ciating with an access point, through which all traffic
passes. This mode is the default.
IBSS mode Also known as IEEE ad-hoc mode or peer-to-peer mode. This
is the standardized method of operating without an access
point. Stations associate with a service set. However,
actual connections between stations are peer-to-peer.
Host AP In this mode the driver acts as an access point (base sta-
tion) for other cards.
monitor mode In this mode the driver is able to receive packets without
associating with an access point. This disables the
internal receive filter and enables the card to capture
packets from networks which it wouldn't normally have
access to, or to scan for access points.
The pgt driver can be configured to use hardware Wired Equivalent Privacy
(WEP). It is strongly recommended that WEP not be used as the sole mech-
anism to secure wireless communication, due to serious weaknesses in it.
The pgt driver can be configured at runtime with ifconfig(8) or on boot
The driver needs a set of firmware files which are loaded when an inter-
face is brought up:
These firmware files are not free because Conexant refuses to grant dis-
tribution rights. In fact they have rebuffed thousands of attempts to
start a dialogue on this issue. As a result, even though OpenBSD
includes the driver, the firmware files cannot be included and users have
to download these files on their own.
A prepackaged version of the firmware can be installed using
The following cards are among those supported by the pgt driver:
Card Chip Bus
3COM 3CRWE154G72 ISL3880 CardBus
D-Link DWL-g650 A1 ISL3890 PCI
I-O Data WN-G54/CB ISL3890 PCI
I4 Z-Com XG-600 ISL3890 PCI
I4 Z-Com XG-900 ISL3890 PCI
Intersil PRISM Indigo ISL3877 PCI
Intersil PRISM Duette ISL3890 PCI
NETGEAR WG511 (Taiwanese, not Chinese) ISL3890 CardBus
PLANEX GW-DS54G ISL3890 PCI
SMC EZ Connect g 2.4GHz SMC2802W ISL3890 PCI
SMC EZ Connect g 2.4GHz SMC2835W-v2 ISL3890 CardBus
SMC 2802Wv2 ISL3890 PCI
Soyo Aerielink ISL3890 CardBus
ZyXEL ZyAIR G-100 ISL3890 CardBus
The following example scans for available networks:
# ifconfig pgt0 scan
The following hostname.if(5) example configures pgt0 to join network
``mynwid'', using WEP key ``mywepkey'', obtaining an IP address using
The following hostname.if(5) example creates a host-based access point on
inet 192.168.1.1 255.255.255.0
arp(4), cardbus(4), ifmedia(4), intro(4), netintro(4), pci(4),
hostname.if(5), hostapd(8), ifconfig(8)
The pgt driver first appeared in OpenBSD 4.0.
The pgt driver was originally written for FreeBSD by Brian Fundakowski,
and then rewritten for OpenBSD by Marcus Glocker and Claudio Jeker.
Host AP mode doesn't support power saving. Clients attempting to use
power saving mode may experience significant packet loss (disabling power
saving on the client will fix this).
BSD March 24, 2017 BSD