PCN(4) BSD Kernel Interfaces Manual PCN(4)
pcn -- AMD PCnet/PCI Fast Ethernet device driver
The pcn driver provides support for PCI Ethernet adapters and embedded
controllers based on the AMD PCnet/FAST, PCnet/FAST+, PCnet/FAST III,
PCnet/PRO and PCnet/Home Ethernet controller chips.
The PCnet/PCI chips include a 100Mbps Ethernet MAC and support both a
serial and MII-compliant transceiver interface. They use a bus master
DMA and a scatter/gather descriptor scheme. The AMD chips provide a
mechanism for zero-copy receive, providing good performance in server
environments. Receive address filtering is provided using a single per-
fect filter entry for the station address and a 64-bit multicast hash ta-
The pcn driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to rc.conf(5).
10baseT/UTP Set 10Mbps operation. The ifconfig(8) mediaopt option can
also be used to select either 'full-duplex' or 'half-duplex'
100baseTX Set 100Mbps (Fast Ethernet) operation. The ifconfig(8)
mediaopt option can also be used to select either
'full-duplex' or 'half-duplex' modes.
The pcn driver supports the following media options:
full-duplex Force full duplex operation
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
The pcn driver supports adapters and embedded controllers based on the
AMD PCnet/FAST, PCnet/FAST+, PCnet/FAST III, PCnet/PRO and PCnet/Home
Fast Ethernet chips:
o AMD Am53C974/Am79C970/Am79C974 PCnet-PCI
o AMD Am79C970A PCnet-PCI II
o AMD Am79C971 PCnet-FAST
o AMD Am79C972 PCnet-FAST+
o AMD Am79C973/Am79C975 PCnet-FAST III
o AMD Am79C976 PCnet-PRO
o AMD PCnet/Home HomePNA
o Allied-Telesis LA-PCI
o Contec C-NET(98)S (PC-98)
o NEC SV-98/2-B05, B06
pcn%d: couldn't map ports/memory A fatal initialization error has
pcn%d: couldn't map interrupt A fatal initialization error has occurred.
pcn%d: watchdog timeout The device has stopped responding to the net-
work, or there is a problem with the network connection (e.g. a cable
pcn%d: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
pcn%d: no memory for tx list The driver failed to allocate an mbuf for
the transmitter ring when allocating a pad buffer or collapsing an mbuf
chain into a cluster.
pcn%d: chip is in D3 power state -- setting to D0 This message applies
only to adapters which support power management. Some operating systems
place the controller in low power mode when shutting down, and some PCI
BIOSes fail to bring the chip out of this state before configuring it.
The controller loses all of its PCI configuration in the D3 state, so if
the BIOS does not set it back to full power mode in time, it will not be
able to configure it correctly. The driver tries to detect this condi-
tion and bring the adapter back to the D0 (full power) state, but this
may not be enough to return the driver to a fully operational condition.
If you see this message at boot time and the driver fails to attach the
device as a network interface, you will have to perform a warm boot to
have the device properly configured.
Note that this condition only occurs when warm booting from another oper-
ating system. If you power down your system prior to booting FreeBSD,
the card should be configured correctly.
arp(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8)
AMD PCnet/FAST, PCnet/FAST+ and PCnet/Home datasheets,
The pcn device driver first appeared in FreeBSD 4.3.
The pcn driver was written by Bill Paul <wpaulATosd.com>.
BSD September 13, 2004 BSD