SOUND(4) BSD Kernel Interfaces Manual SOUND(4)
sound, pcm, snd -- FreeBSD PCM audio device infrastructure
For a card with bridge driver support, and a PnP card:
For a card without bridge driver support, and a non-PnP card, the follow-
ing lines may be required in /boot/device.hints:
Note: There exists some ambiguity in the naming at the moment (sound,
pcm, snd). It will be resolved soon by renaming device sound to device
snd, and doing associated changes.
The sound driver provides support for PCM audio play and capture. This
driver also supports various PCI, WSS/MSS compatible, ISA sound cards,
and AC97 mixer. Once the sound driver attaches, supported devices pro-
vide audio record and playback channels. The FreeBSD sound system pro-
vides dynamic mixing ``VCHAN'' and rate conversion ``soft formats''.
True full duplex operation is available on most cards.
If the sound card is supported by a bridge driver, the sound driver works
in conjunction with the bridge driver.
Apart from the usual parameters, the flags field is used to specify the
secondary DMA channel (generally used for capture in full duplex cards).
Flags are set to 0 for cards not using a secondary DMA channel, or to
0x10 + C to specify channel C.
The driver works best with WSS/MSS cards, which have a very clean archi-
tecture and an orthogonal set of features. They also happen to be among
the cheapest audio cards on the market.
The driver does its best to recognize the installed hardware and drive it
correctly so the user is not required to add several lines in
/boot/device.hints. For PCI and ISA PnP cards this is actually easy
since they identify themselves. For legacy ISA cards, the driver looks
for MSS cards at addresses 0x530 and 0x604 (unless overridden in
In general, the module snd_foo corresponds to device snd_foo and can be
loaded by the boot loader(8) via loader.conf(5) or from the command line
using the kldload(8) utility. Options which can be specified in
snd_driver_load (``NO'') If set to ``YES'', this option loads all
snd_emu10k1_load (``NO'') If set to ``YES'', only the SoundBlaster
5.1 driver and dependent modules will be loaded.
snd_foo_load (``NO'') If set to ``YES'', load driver for
To define default values for the different mixer channels, set the chan-
nel to the prefered value using hints, e.g.: hint.pcm.0.line="0". This
will mute the input channel per default.
Each device can optionally support more playback channels that physical
hardware provides by using ``virtual channels'' or VCHANs. VCHAN options
can be configured via the sysctl(8) interface but can only be manipulated
while the device is inactive.
The following sysctl(8) variables are available:
hw.snd.pcm%d.buffersize Configure the amount of DMA bufferspace
available for a device.
hw.snd.targetirqrate Set the default block size such that
continuous playback will achieve this
IRQ rate. This value can be tuned to
improve application performance.
Increase this value when the sound lags
and decrease it if sound stutters or
hw.snd.unit When using devfs(5), the default device
for /dev/dsp. Equivalent to a symlink
from /dev/dsp to
hw.snd.report_soft_formats Controls the internal format conversion
if it is available transparently to the
application software. When disabled or
not available, the application will
only be able to select formats the
device natively supports.
hw.snd.verbose Level of verbosity for the /dev/sndstat
device. Higher values include more
output and the highest level, three,
should be used when reporting problems.
Other options include:
0 Installed devices and their allo-
cated bus resources.
1 The number of playback, record,
virtual channels, and flags per
2 Channel information per device
including the channel's current
format, speed, and pseudo device
statistics such as buffer overruns
and buffer underruns.
3 File names and versions of the cur-
rently sound loaded modules.
hw.snd.maxautovchans Global VCHAN setting that only affects
devices that have only one playback
channel. The sound system will dynami-
cally create up this many VCHANs. Set
to ``0'' if no VCHANS are desired.
hw.snd.pcm%d.vchans The current number of VCHANs allocated
per device. This can be set to preal-
locate a certain number of VCHANs.
Setting this value to ``0'' will dis-
able VCHANs for this device.
On devices that have more than one recording source (ie: mic and line),
there is a corresponding /dev/dspr%d.%d device.
Channel statistics are only kept while the device is open. So with situ-
ations involving overruns and underruns, consider the output while the
errant application is open and running.
The driver supports most of the OSS ioctl() functions, and most applica-
tions work unmodified. A few differences exist, while memory mapped
playback is supported natively and in Linux emulation, memory mapped
recording is not due to VM system design. As a consequence, some appli-
cations may need to be recompiled with a slightly modified audio module.
See <sys/soundcard.h> for a complete list of the supported ioctl() func-
Below we include a list of supported codecs/cards. If your sound card is
not listed here, it may be supported by a bridge driver.
CS4237, CS4236, CS4232, CS4231 (ISA)
All these cards work perfectly in full duplex using the MSS mode.
This chipset is used, among others, on the A/Open AW35 and AW32, on
some Intel motherboards, and (the CS4231) on some non-PnP cards.
The CS4232 is reported as buggy in the Voxware documentation but I am
not sure if this is true. On one of my Intel motherboards, capture
does not work simply because the capture DMA channel is not wired to
the ISA DMA controller.
Yamaha OPL-SAx (ISA)
Works perfectly in all modes. This chip is used in several PnP
cards, but also (in non-PnP mode) on motherboards and laptops (e.g.,
the Toshiba Libretto).
The chip is buggy, but the driver has many workarounds to make it
work in full duplex because for some time these were the only full
duplex cards I could find. U-law format uses U8 format internally
because of a bug in the chip.
Trident 4DWave DX/NX (PCI)
ENSONIQ AudioPCI ES1370/1371 (PCI)
Creative Labs SoundBlaster PCI is supported as well.
ESS Solo-1/1E (PCI)
NeoMagic 256AV/ZX (PCI)
The sound drivers may create the following device nodes:
/dev/audio%d.%d Sparc-compatible audio device.
/dev/dsp%d.%d Digitized voice device.
/dev/dspW%d.%d Like /dev/dsp, but 16 bits per sample.
/dev/dspr%d.%d Should be connected to a record codec.
/dev/sndstat Current sound status, including all channels and driv-
The first number in the device node represents the unit number of the
sound device. All sound devices are listed in /dev/sndstat. Additional
messages are sometimes recorded when the device is probed and attached,
these messages can be viewed with the dmesg(8) utility.
ac97: dac not ready AC97 codec is not likely to be accompanied with the
unsupported subdevice XX A device node is not created properly.
Some features of your cards (e.g., global volume control) might not be
supported on all devices.
The sound device driver first appeared in FreeBSD 2.2.6 as pcm, written
by Luigi Rizzo. It was later rewritten in FreeBSD 4.0 by Cameron Grant.
The API evolved from the VOXWARE standard which later became OSS stan-
snd_csa(4), snd_gusc(4), snd_sbc(4), devfs(5), loader.conf(5), dmesg(8),
The OSS API, http://www.opensound.com/pguide/oss.pdf.
Luigi Rizzo <luigiATiet.it> initially wrote the pcm device driver
and this manual page. Cameron Grant <gandalfATvilnya.uk> later
revised the device driver for FreeBSD 4.0. Seigo Tanimura
<tanimuraATr.jp> revised this manual page. It was then
rewritten for FreeBSD 5.2.
BSD August 28, 2004 BSD