PCMCIA(4) BSD Kernel Interfaces Manual PCMCIA(4)
pcmcia -- introduction to PCMCIA (PC Card) support
pcic0 at isa? port 0x3e0 iomem 0xd0000 iosiz 0x10000
pcic1 at isa? port 0x3e2 iomem 0xe0000 iosiz 0x4000
pcic2 at isa? port 0x3e4 iomem 0xe0000 iosiz 0x4000
pcic* at isapnp?
pcic* at pci? dev?
pcmcia* at pcic?
tcic0 at isa? port 0x240 iomem 0xd0000 iosiz 0x10000
pcmcia* at tcic?
pcic* at cbus?
pcmcia* at pcic?
tslot* at sbus?
pcmcia* at tslot?
stp* at sbus?
pcmcia* at stp?
pxapcic0 at pxaip?
pcmcia* at pxapcic?
# all architectures
cbb* at pci?
cardslot* at cbb? flags 0x0000
pcmcia* at cardslot?
The pcmcia subsystem provides machine-independent bus support and drivers
for PCMCIA (PC Card) devices.
OpenBSD provides support for the following devices. Note that not all
architectures support all devices.
gpr(4) GemPlus GPR400 smartcard reader
Serial interfaces and modems
com(4) serial communications interface
Wired network interfaces
ep(4) 3Com EtherLink III and Fast EtherLink III 10/100 Ether-
ne(4) NE2000 and compatible 10/100 Ethernet device
sm(4) SMC91C9x and SMC91C1xx-based 10/100 Ethernet device
xe(4) Xircom-based 16-bit PCMCIA 10/100 Ethernet device
Wireless network interfaces
an(4) Aironet Communications 4500/4800 IEEE 802.11FH/b wire-
less network device
cnw(4) Xircom CreditCard Netwave wireless network device
malo(4) Marvell Libertas IEEE 802.11b/g wireless network device
wi(4) WaveLAN/IEEE, PRISM 2-3, and Spectrum24 IEEE 802.11b
wireless network device
aic(4) Adaptec AIC-6260 and AIC-6360 SCSI interface
wdc(4) WD100x compatible hard disk controller driver
The supported PCMCIA controllers are those that are i82365 compatible.
On some pcmcia adapters, for instance the sbus(4)-based stp(4), the
pcmcia bus will be mapped in big-endian format instead of the natural
(and preferred) little endian format. Unfortunately such controllers
lack the hardware facility to swap bytes, and it is not efficient to con-
vert all drivers to always know about this. While 8 bit drivers can
invisibly work on such a bus, 16 bit drivers will need modification to
handle this. So far, wi(4) is the only driver to require these modifica-
If the pcmcia adapter is not detected, or if pcmcia events (such as card
insertion) do not occur, there may be a PCI card BIOS mapped in the same
memory space the pcmcia driver is configured to use (this is often the
case with Ethernet card boot ROMs). The output from dmesg(8) should con-
tain a line beginning with ``bios0'' that lists the memory address and
size of mapped regions. If there is a conflict, you can use
boot_config(8) to change the iomem parameter of the pcic device to a non-
overlapping address, such as 0xd8000 for pcic0. Some experimentation may
be required to find a working value; in some cases the size parameter of
the pcic device may need to be decreased to avoid a conflict.
cardbus(4), intro(4), isa(4)
The pcmcia driver appeared in OpenBSD 2.3.
BSD April 30, 2017 BSD