PAD(4) Kernel Interfaces Manual PAD(4)
pad -- Pseudo audio device driver
audio* at audiobus?
pad is a pseudo-device driver which provides support for feeding back PCM
data from a consumer of the audio(4) API to userland.
The pad pseudo-device driver receives data from /dev/soundN and feeds the
raw PCM output to /dev/padN.
The following example streams an MP3 to an Apple AirTunes compatible
$ rtunes - < /dev/pad0 &
$ mpg123 -a /dev/sound1 mozart.mp3
The pad driver appeared in NetBSD 5.0.
Jared D. McNeill <jmcneillATinvisible.ca>
NetBSD 6.1.5 November 11, 2007 NetBSD 6.1.5