ONEWIRE(4) BSD Kernel Interfaces Manual ONEWIRE(4)
onewire -- 1-Wire bus
onewire* at gpioow?
onewire* at uow?
onewire* at ioc? (sgi)
onewire* at xheart? (sgi)
1-Wire bus was originally developed by Dallas Semiconductor for connect-
ing integrated circuits. It is commonly used for connecting devices such
as electronic keys, EEPROMs, temperature sensors, real-time clocks, secu-
rity chips, etc.
The onewire driver provides a uniform programming interface layer between
1-Wire master controllers and various 1-Wire slave devices. Each 1-Wire
master controller attaches a onewire framework; several slave devices can
then be attached to the onewire bus.
The driver supports plugging and unplugging slave devices on the fly.
gpioow(4) 1-Wire bus bit-banging through GPIO pin
ioc(4) IOC3 generic workstation I/O device
uow(4) Maxim/Dallas DS2490 USB 1-Wire adapter
xheart(4) Octane core system widget
owctr(4) 1-Wire counter device
owid(4) 1-Wire ID device
owmac(4) 1-Wire Ethernet address
owsbm(4) 1-Wire smart battery monitor device
owserial(4) 1-Wire serial number
owtemp(4) 1-Wire temperature device
The onewire driver first appeared in OpenBSD 4.0.
The onewire driver was written by Alexander Yurchenko
BSD March 28, 2017 BSD